Forum Discussion

Everseeker's avatar
Everseeker
Contributor
9 years ago

How do I thwart Unwanted Process Termination?

OK, First, a snippit of keyword code...

RoutingWorkCenterComboBox  ClickItem     "44555 - VERSATECH - BENTEC - *W"
OkActionButton             ClickButton

Pretty standard stuff. That Combo box is an odd duck though. Once you select "OK" it goes and runs a bunch of processes... takes ~ 45 seconds.  While it does this, the form changes from "Change Routing" to "Change Routing (Not Responding)" It is not dead, it is just doing "other things"... This is how the devs coded it, and I can't change that. I selected the OKActionButton and changed the auto-wait timeout to 60 seconds... 90% of the time, this is fine.

 

So, My issue:

The times it is NOT fine, the "Failure-process" that TC runs differs from the norm. Nrmally, you get a message like "Box xyz not found" and you can trap that and, in code, arrange for a workaround, or branch on "observed" text or... whatever

HOWEVER, In this case, if the Auto-Wait timeout concludes, and TC notices that (Not Responding)... It terminates the offending process!(My program)

The Samtec.ShopFloorControl.AppHost.exe process does not respond. It will be terminated. 

THEN, to make matters worse, it tries to continue my script, which causes all sorts of mayhem as it goes about trying to find stuff on my desktop! (YES, I have Stop on error checked)

 

So:

1. Is this a bug?

2. If not, How do I change the behavior of the Evil(process)Terminator?

 

I would be fine with a nomal error toss... something my script can work with. But it is pretty hard to do much when your application is gone.

 

 

  • Go to project\ properties panel

    there left side panal click Freeze Diagnostics

    try increasing application hanging time out or process filter mode set to Ignore all process

2 Replies

  • NisHera's avatar
    NisHera
    Valued Contributor

    Go to project\ properties panel

    there left side panal click Freeze Diagnostics

    try increasing application hanging time out or process filter mode set to Ignore all process

    • Everseeker's avatar
      Everseeker
      Contributor

      Thank you. That was indeed the issue I was having.

      2 things that were noteworthy about this issue:

       

      1. I did not know WHY it was happening... Solved

      2. While trying to figure out the cause, I had set auto wait timeouts, both over the entire app, AND on the sctions that were pulling up the "frozen" window. AND had added long delays... but the page was closing at 10 seconds... no matter what.

       

      NOW I know... the "Freeze Detection" has a timeout of its very own :)

       

      Thanks Again.