Forum Discussion

Mis3's avatar
Frequent Contributor
3 years ago

Still running V5.5.0

I am still running V5.5.0 and I noticed that V5.6 has been around for a long time.

I clicked Check for Updates in Help, it says "You are using the latest accessible release of SoapUI".   What does this mean?


What is the best way to upgrade with least impact to my projects?


6 Replies

  • richie's avatar
    Community Hero

    Hey Mis3 



    It sounds like there's a defect in SoapUI - cos there's actually v5.7.0 been released, so v5.6 is not the latest.


    You could always navigate to here --> to manually download the latest version.  It's a bit weird that SoapUI isn't finding v5.7.0 as the latest release - but at least you can manually download from the above link.


    The "best way to upgrade with least impact to my projects"?  You can read the release notes for each new version of SoapUI before installing to see if any of the changes might impact your tests. 

    Another option (which is what I tend to do instead) is ignore the release notes initially and download the latest version, but I don't upgrade the existing folder in the program files directory - but install into a separate folder - so that I actually have multiple versions of SoapUI installed at the same time - so that if there's a problem with the latest version, I've still got the previous version to go back to.


    I did notice someone else posted an issue about how the JSON libaries appear to have been updated in v5.7.0 and so some of your tests using JSONPATH might fail due to changes.  So in that instance the API tester involved needed to determine if the work required to the JSONPATH in his tests was worth the upgrade or not.


    Hope this helps,





    • Mis3's avatar
      Frequent Contributor

      Thanks for your help.

      V5.7 is still new, maybe I should just upgrade to V5.6.





      • Mis3's avatar
        Frequent Contributor

        I downloaded SoapUI-5.6.1-windows-bin, unzipped it but I cannot found an executable file to update.

        I tried SoapUI-5.6.0-windows-bin, same result.


        Did i download the wrong files?