Forum Discussion

eForester's avatar
Occasional Visitor
6 months ago doesn't work anymore

I have a classic code for accesing LDAP like: 


ldap = LDAP.newInstance(ip, <root>, <rootpassword>)

it worked fine long time. Bur resently it stopps to work. I get "unable to resolve class" - Error

oorg.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: Script2.groovy: 1: unable to resolve class @ line 1, column 1. import ^ org.codehaus.groovy.syntax.SyntaxException: unable to resolve class @ line 1, column 1. at org.codehaus.groovy.ast.ClassCodeVisitorSupport.addError( at org.codehaus.groovy.control.ResolveVisitor.visitClass( at org.codehaus.groovy.control.ResolveVisitor.startResolving( at org.codehaus.groovy.control.CompilationUnit.lambda$new$16( at org.codehaus.groovy.control.CompilationUnit$ISourceUnitOperation.doPhaseOperation( at org.codehaus.groovy.control.CompilationUnit.compile( at groovy.lang.GroovyClassLoader.doParseClass( at groovy.lang.GroovyClassLoader.lambda$parseClass$3( at org.codehaus.groovy.runtime.memoize.StampedCommonCache.compute( at org.codehaus.groovy.runtime.memoize.StampedCommonCache.getAndPut( at groovy.lang.GroovyClassLoader.parseClass( at groovy.lang.GroovyShell.parseClass( at groovy.lang.GroovyShell.parse( at groovy.lang.GroovyShell.parse( at groovy.lang.GroovyShell.parse( at at at at com.eviware.soapui.impl.wsdl.panels.teststeps.GroovyScriptStepDesktopPanel$RunAction$ at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker( at java.base/java.util.concurrent.ThreadPoolExecutor$ at java.base/ Script2.groovy: 2: unable to resolve class @ line 2, column 1. import

I chekced if the libraries are existing in \bin\ext. And yes jar-file is here. I also tried to copy files into \lib -> the same problem exists.

I setup a new VM with Windows 11 and SoapUI 5.6.1 and still unable to use my code.

I tried to impoert * instead of LDAP like:


Result: groovy.lang.MissingPropertyException: No such Property: LDAP for Class


How to bring the code to run again?

1 Reply

  • Humashankar's avatar
    Champion Level 2

    Hi eForester 


    Try making over the LDAP property from within the package, you need to import the specific class or classes that define this property

    LDAP property is defined in a class named LdapConnector within the package

    Hope this helps - Happy to help further!!
    Thank you very much and have a great one!

    Warm regards