Forum Discussion

SriniG's avatar
5 years ago

Unable to initialize script engine - scripts are not running



when i'm trying to run the script routine testcomplete exit witout executing the script and not showing any detials in results log and i tried to debug but its not going the function/break point. Could you please help me how to overcome this issue.


function sampletest()


see the results screens:


  • Thank you all for helping meπŸ˜€

    I have tried with all your suggestions and nothing is worked out then we formatted the desktop and reinstalled the TestComplete then script engine started working. We are suspecting that McAfee or Zscaler or Cylance might blocked the TestComplete script engines. Anyways it started working after formatting the desktop.

17 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    Your function is called "Acceptance_Test" in the Main unit.... but the code you showed us is something called "sampletest" in some unknown unit.  So... we are going to have a hard time debugging what you're trying to do.  Please, if you can, share more details about the code you're trying to execute.

      • tristaanogre's avatar
        Esteemed Contributor

        Ok... now we see an error message that was not explained before.

        What happens if you disable that extension (File -> Install Script Extensions -> Uncheck the Clipboard extension)?  Will things run then?

  • Wamboo's avatar
    Community Hero


    That's strange I can't reproduce this error on my TestComplete version. Can You show us the unit file and the function inside it?