Forum Discussion

rpfaucher1's avatar
4 years ago

TestComplete 14.73 update, not downloading?

Howdy, is anyone else having an issue trying to update to TC 14.73?


When I try to use the check updates feature from TestComplete, shows I can update to 14.73, so I click download and install.... then quickly get an error message to the effect of "Unable to download the update" error message... 


I tried this on at least 4 of our test machines... anyone else having same issue?


I know I can manually download, which I have done on one machine and then install... which is good, and then am immediately informed there is a patch for Firefox... 


So, anyways, just checking if others have same issue(s)?



4 Replies

  • V_1's avatar
    Occasional Contributor

    Hi there


    I had this same problem and support told me they'd not seen this before. They just advised to download manually which much like yourself I did and that worked fine...of course I then had to patch firefox 🙂

    • rpfaucher1's avatar

      Interesting, as I'll probably log a support call on this, as we are seeing it on a number of machines.





      • sonya_m's avatar
        SmartBear Alumni (Retired)

        Hi! There's a confirmed connection issue, the Team is working to fix it.

        For now, the workaround is downloading it from and installing manually.