Forum Discussion

DonnaC's avatar
Occasional Contributor
7 years ago

Chrome extension is enabled but testcomplete cannot detect it when recording new test

I'm unable to record tests in TestComplete at moment using Chrome as it is unable to detect that the extension is enabled. TestComplete v12.31.1833.7 with SmartBear Test Extension v12.31.1833. My existing tests run just fine using Chrome and I'm just having issues when I want to record new ones or add to existing ones. Has anyone else experienced this and how did you get TestComplete to recognise the extension was enable?
  • I have the solution for this issue now thanks to an online meeting with Smartbear. 


    The problem in the end was down to the tcCrHost.exe in the tcCrExtension folder being for the wrong version of the extension even after a complete reinstall of everything. 


    The solution was to uninstall TestComplete and delete the tcCrExtension folder. Then reinstall TestComplete. The extension didn't automatically get added to Chrome for me but a simple dragging the tcCrExtension.crx to Chrome fixed that. 


    I can now record tests again without issue. A bit of a long winded way to fix it but at least it is now resolved. No idea why it happened in the first place though.

7 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    Just to note, I just tried a quick record of something against my Chrome browser on the SmartBear site.  I'm running Windows 10, Chrome Version 61.0.3163.91, and TestComplete 12.31.  This worked just fine. I've tried it in keyword tests as well and that works, too.


    function Test3()
        var browser;
        browser = Aliases.browser;;

    Basically, this means that there's nothing specifically wrong with the application or the extension but something uniquely environmental to your implementation.  So, have you tried disabling and re-enabling the extension? Have you recently upgraded your TestComplete installation? Did you try a repair of your TestComplete installation?


    I honestly didn't do anything "special" to make sure the extension was working so I can't help you beyond just the usual "reinstall" kind of help.

    • DonnaC's avatar
      Occasional Contributor
      I have already tried disabling and enable but to no avail and TestComplete update was a few weeks ago but this was the first time I need to record a test since the update. I'll try a repair and see if that fixes it. It's being run on a Windows 8.1 environment so maybe that is where the issue lies. I'll do some more investigating.
      • DonnaC's avatar
        Occasional Contributor

        Done some more investigating and still not having any luck. 


        I've tried the following-

         - disabling then running a record and switching it to enabled when prompted 

         - completely uninstalling Chrome and reinstalling it. Then running a modify on TestComplete

         - running a repair for TestComplete

         - removed extension from Chrome then reinstalled extension via dragging in from common files.

         - disabled every other extension in Chrome before trying to run a record.


        No idea what else to try as nothing is working. It appears to recognise the browser but then crashes out when I start to click any links/fields and says it's not enabled.


        Any other suggestions on what I could try?