Forum Discussion

hok's avatar
hok
New Contributor
4 years ago

SoapUI 5.6.0 upgrade keeps JRE 8 : java.lang.UnsupportedClassVersionError

When I started SoapUI 5.5.0 today, an upgrade to 5.6.0 was offered.

However, after the upgrade, SoapUI doesn't start; it fails with this error:

 

java.lang.UnsupportedClassVersionError: com/eviware/soapui/SoapUI has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

 

I checked the jre contained within SoapUI; it is still "1.8.0_181", but obviously at least Java 9 is required.

 

I'm on Ubuntu 18.04.4 LTS.

  • Copying a more recent JRE (Java 11) into the jre subfolder (as suggested here) fixed it.

6 Replies

  • hok's avatar
    hok
    New Contributor

    Copying a more recent JRE (Java 11) into the jre subfolder (as suggested here) fixed it.

    • danzone's avatar
      danzone
      New Member

      I confirm that this solved the issue also for me (SO: Ubuntu 20.04). I used AdoptOpenJDK11 and it worked.

      • jmordonez's avatar
        jmordonez
        New Contributor

        Hi i'm having the same trouble but i cant find the jre subfolder inside of ~/SmartBear/SoapUI-5.6.0/, in wich directory i have to search?