Forum Discussion

richie's avatar
Community Hero
4 years ago

JDBC Config NOT Displayed in Preferences?



I've just dl'd SoapUI v5.6.0 and tried setting up a db connection but when I tried launching the JDBC option in the Preferences, the option is not displayed.


I had this issue previously with ReadyAPI! a while back (where the JDBC option just wasnt being displayed in the Preferences) but I havent noticed it with SoapUI before.


Can someone else check if they can see the JDBC component in the Preferences please if theyre running v5.6.0?


also if anyone's running v5.5.0 could they check if the JDBC option is present please?  as I might downgrade if necessary.





2 Replies

  • Hello Rich,


    I use ReadyAPI 2.7.0 (licensed).  In the preferences, I can only register the db drivers to use.  Db connections are then defined within the Environments UI.


    I also have a copy of SoapUI 5.6.0.  I cannot find any way to register drivers or create any sort of connection in the Preferences.  Nor do I have an Environments UI, probably because it's unlicensed.


    There is the JDBC test step, but this seems somewhat pointless as you cannot select a driver to use.  You can type one in and specific a conn string (I cribbed both details from one of my  Ready API tests), but when clicking Test Connection, SoapUI says..... Failed to init connection for driver [oracle.jdbc.driver.OracleDriver], connectionString [jdbc:oracle:thin:*******/*****@server:port:db]

    Obviously, I've anonymised the above.  But without being able to register, or say where the driver is, I cannot see how you can make a db connection.

    • richie's avatar
      Community Hero

      Hey ChrisA 



      yeah agree with you - however I know the JDBC used to be available in SoapUI preferences, cos I setup a connection on a version about 18-24months ago.


      I have ReadyAPI! installed on my other laptop v3.4.0 and I've been using it since about v1.9 and i remember sometime when I had version v2.x.x the same issue appeared to occur - i.e., -  for some reason, the JDBC option was missing from the preferences, so I was wondering if the same issue was occurring in SoapUI as ReadyAPI!


      Ta for confirming - I'll give downgrading a shot and keep dropping it until i get a version where it appears again!


      nice one