Forum Discussion

hyavuz's avatar
New Member
10 years ago

How to enable TLS 1.2 in SoapUI

I need to connect a webservice which only accept a connection established via TLS 1.2.


I added the line -Dsoapui.https.protocols=TLSv1.2 in the file SoapUI-5.0.0.vmoptions and it's not working.


Any help on this.




  • Check this link


    As per this, you also need to set SSL version as well, something like below


33 Replies

  • bplummer's avatar
    Frequent Visitor

    I have SoapUI 5.3.0 and adding the line below to the vmoptions file worked for me!  I can now communicate with a SOAP service running on a server that only has TLS 1.2 enabled.


    The file I added setting to:

    C:\Program Files (x86)\SmartBear\SoapUI-5.3.0\bin\SoapUI-5.3.0.vmoptions


    Line I added to end of file.



    Good luck!

    • milksama's avatar

      I can definitively say your suggestion resolved the issue for me (SoapUI 5.3.0, Windows 7 Enterprise x64 SP1). This is after more time wasted than I care to admit on numerous suggestions provided on various websites over the years.


      Description of problem

      Attempting to "Update Definition" by adding the WSDL via the hosted web service always resulted in a failure:

      though I could download the WSDL and add manually, no problem. Once the WSDL was added, however, attempting to call any method resulted in an exception:





      to "%PROGRAMFILES%\SmartBear\SoapUI-5.3.0\bin\SoapUI-5.3.0.vmoptions" resolved the issue completely -- I'm able to add/update the WSDL and invoke methods successfully.


    • nmrao's avatar
      Champion Level 3

      Check this link


      As per this, you also need to set SSL version as well, something like below


      • clum's avatar
        New Member

        SSLv3 is dead thanks to POODLE. Is there a way to restrice SoapUI from using SSL and always use TLS? 


        setting up -Dsoapui.https.protocols=TLSv1.2 does not seem to prevent SSL connections

  • yaggi's avatar
    Regular Visitor

    I ran into same issues with enabling TLS 1.2 in SoapUI, and adding those parameters helped. But it's only for desktop version. Does anyone knows how to enable TLS 1.2 in SoapUI maven plugin?


    • nmrao's avatar
      Champion Level 3
      Not really aware of maven. But there should be a way to pass system properties or using JAVA_OPTS
    • nmrao's avatar
      Champion Level 3
      Please go thru trailing messages, which already has answer I believe.
      • AravindanR's avatar
        Occasional Contributor

        what is the default TLS protocol version of Ready API 1.6.0?

  • Hi Team,

    I am also getting Handshake Failure while sending https request from my soap ui.

    SOAP UI version : 4.5.2


    It used to work earlier and seems recently some change for the accepted cipher have been made at target system (while I am trying to hit) it is not working.

    Target system confirmed they are using AES256-SHA256 with TLSv1.2. they also support TLSv1.0


    I tried making following changes to vmoptions file




    also tried all the variations for cipher suite name as below





    After putting cipher suite is soap UI vmoptions file it is resulting into unsupported cipher suite error.

    Could you please through some hints to overcome this issue.


    Many Thanks