Forum Discussion

silygose's avatar
Occasional Contributor
10 years ago

SoapUI Pro 5.1.2 hangs on Mac OS X 10.8.5

SoapUI Pro 5.1.2 hangs on Mac OS X 10.8.5


I installed SoapUI Pro 5.1.2 on MAC OS X 10.8.5. When I run SoapUI Pro it just hangs. Any ideas on how to resolve?

Thanks in advance

10 Replies

  • The steps on worked for me (on OS X 10.10.3):


    1. Start ‘Activity Monitor’ and Force Kill your dead soapUI process. [Or use Command-Option-Escape to force quit it.]
    2. In Finder, /Applications/SmartBear/ > Show Package Contents.
    3. Edit /Applications/SmartBear/
    4. Uncomment this line# JAVA_OPTS="$JAVA_OPTS -Dsoapui.browser.disabled=true". [In other words, remove the "#" to stop it being a comment.]
    5. Edit /Applications/SmartBear/
    6. Add -Dsoapui.browser.disabled=true.
    7. Start soapUI.

    [In those paths, change soapUI-5.0.0 to match your version. For me it is soapUI-5.1.3.]


    Hope this helps.

    • Mzamo's avatar
      New Member

      This awesome post !! it worked very well. How did you get this to work. Well done , nice post

    • nev3rm0re's avatar
      New Member

      Registered here just to thank you for instructions - they worked perfectly for me (SoapUI-5.3.0 on macOS Sierra/10.12.4)

    • csk's avatar
      Occasional Visitor

      Just registered to say "Thank you PhilipSharman" for the given solution.


      It worked in my case with SOAP-UI Version 5.3.0 (5.3.0) :smileyvery-happy:



  • I have the same on Mac OS 10.10.2 Mac Book Pro.

    When I disable Wifi , it opens faster... but then it hangs again.

    Kind of make it impossible to even start somewhere

    Free version. just installed.. Not Pro

    IS there any workaround for this somewhere?

    • gerhardpret's avatar
      New Contributor

      Updated to Java 8 Update 40 just to be sure.. but same thing..

      • nmrao's avatar
        Champion Level 3
        any thing obvious that is seen in the logs?
  • I also just registered to say thanks because I was already desperate and the solution worked for me with 5.3.0.


    I also wanted to say that is incredible that after all the time (and versions) this problem is not yet solved.


    This does not give me confidence to buy the full product.